Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.yamcs/yamcs-core
  4. ›
  5. CVE-2026-44595

CVE-2026-44595: Yamcs vulnerable to unauthorized user enumeration via IAM API endpoints

May 27, 2026

The IAM API endpoints (listUsers, getUser, listGroups, and getGroup) in yamcs-core do not enforce the required SystemPrivilege.ControlAccess check. As a result, any authenticated user (even those with low or no privileges) can enumerate all user accounts in the system, including their usernames, superuser status, and group memberships.

This constitutes a broken access control vulnerability (CWE-862) that leaks sensitive user information.

References

  • github.com/advisories/GHSA-p2rj-mrmc-9w29
  • github.com/yamcs/yamcs/security/advisories/GHSA-p2rj-mrmc-9w29
  • nvd.nist.gov/vuln/detail/CVE-2026-44595

Code Behaviors & Features

Detect and mitigate CVE-2026-44595 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.12.7

Fixed versions

  • 5.12.7

Solution

Upgrade to version 5.12.7 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-862: Missing Authorization

Source file

maven/org.yamcs/yamcs-core/CVE-2026-44595.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.