Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.xwiki.platform/xwiki-platform-security-requiredrights-default
  4. ›
  5. CVE-2025-32974

CVE-2025-32974: org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type

April 29, 2025 (updated April 30, 2025)

When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn’t consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation.

To reproduce, as a user without script right, create a class with a TextArea property, create page with an object of that class and a Velocity macro in its content. Then, as an admin, try editing that page. Normally, there should be a warning but in vulnerable versions of XWiki, there is no warning.

References

  • github.com/advisories/GHSA-mvgm-3rw2-7j4r
  • github.com/xwiki/xwiki-platform
  • github.com/xwiki/xwiki-platform/commit/153dbfa2ef1a7a0a644fe3f889684c6a8738c5fc
  • github.com/xwiki/xwiki-platform/security/advisories/GHSA-mvgm-3rw2-7j4r
  • jira.xwiki.org/browse/XWIKI-22002
  • nvd.nist.gov/vuln/detail/CVE-2025-32974

Code Behaviors & Features

Detect and mitigate CVE-2025-32974 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 15.9-rc-1 before 15.10.8, all versions starting from 16.0.0-rc-1 before 16.2.0

Fixed versions

  • 15.10.8
  • 16.2.0

Solution

Upgrade to versions 15.10.8, 16.2.0 or above.

Impact 9 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-116: Improper Encoding or Escaping of Output
  • CWE-269: Improper Privilege Management

Source file

maven/org.xwiki.platform/xwiki-platform-security-requiredrights-default/CVE-2025-32974.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.