Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.xwiki.platform/xwiki-platform-rendering-wikimacro-store
  4. ›
  5. CVE-2025-49581

CVE-2025-49581: XWiki allows remote code execution through default value of wiki macro wiki-type parameters

June 13, 2025 (updated November 10, 2025)

Any user with edit right on a page (could be the user’s profile) can execute code (Groovy, Python, Velocity) with programming right by defining a wiki macro. This allows full access to the whole XWiki installation and thus impacts its confidentiality, integrity and availability. The main problem is that if a wiki macro parameter allows wiki syntax, its default value is executed with the rights of the author of the document where it is used. This can be exploited by overriding a macro like the children macro that is used in a page that has programming right like the page XWiki.ChildrenMacro and thus allows arbitrary script macros. The full reproduction steps can be found in the original issue.

References

  • github.com/advisories/GHSA-9875-cw22-f7cx
  • github.com/xwiki/xwiki-platform
  • github.com/xwiki/xwiki-platform/commit/c99d501ed41cbee6a3c02ff927714531570789de
  • github.com/xwiki/xwiki-platform/security/advisories/GHSA-9875-cw22-f7cx
  • jira.xwiki.org/browse/XWIKI-22760
  • nvd.nist.gov/vuln/detail/CVE-2025-49581

Code Behaviors & Features

Detect and mitigate CVE-2025-49581 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 12.8-rc-1 before 16.4.7, all versions starting from 11.10.11, all versions starting from 12.6.3, all versions starting from 16.5.0-rc-1 before 16.10.3, all versions starting from 17.0.0-rc-1 before 17.0.0

Fixed versions

  • 16.4.7
  • 16.10.3
  • 17.0.0

Solution

Upgrade to versions 16.10.3, 16.4.7, 17.0.0 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

maven/org.xwiki.platform/xwiki-platform-rendering-wikimacro-store/CVE-2025-49581.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:49 +0000.