Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.springframework/spring-webmvc
  4. ›
  5. CVE-2023-20860

CVE-2023-20860: Spring Framework is vulnerable to security bypass via mvcRequestMatcher pattern mismatch

March 28, 2023 (updated September 23, 2025)

Spring Framework running version 6.0.0 - 6.0.6 or 5.3.0 - 5.3.25 using “**” as a pattern in Spring Security configuration with the mvcRequestMatcher creates a mismatch in pattern matching between Spring Security and Spring MVC, and the potential for a security bypass.

References

  • github.com/advisories/GHSA-7phw-cxx7-q9vq
  • github.com/spring-projects/spring-framework
  • github.com/spring-projects/spring-framework/commit/202fa5cdb3a3d0cfe6967e85fa167d978244f28a
  • nvd.nist.gov/vuln/detail/CVE-2023-20860
  • security.netapp.com/advisory/ntap-20230505-0006
  • spring.io/security/cve-2023-20860

Code Behaviors & Features

Detect and mitigate CVE-2023-20860 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.3.0 before 5.3.26, all versions starting from 6.0.0 before 6.0.7

Fixed versions

  • 6.0.7
  • 5.3.26

Solution

Upgrade to versions 5.3.26, 6.0.7 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Source file

maven/org.springframework/spring-webmvc/CVE-2023-20860.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.