Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.springframework.security/spring-security-core
  4. ›
  5. CVE-2025-41248

CVE-2025-41248: Spring Security annotation detection mechanism has authorization bypass

September 16, 2025

The Spring Security annotation detection mechanism may not correctly resolve annotations on methods within type hierarchies with a parameterized super type with unbounded generics. This can be an issue when using @PreAuthorize and other method security annotations, resulting in an authorization bypass.

Your application may be affected by this if you are using Spring Security’s @EnableMethodSecurity feature.

You are not affected by this if you are not using @EnableMethodSecurity or if you do not use security annotations on methods in generic superclasses or generic interfaces.

This CVE is published in conjunction with CVE-2025-41249 https://spring.io/security/cve-2025-41249 .

References

  • github.com/advisories/GHSA-8v5q-rhf3-jphm
  • github.com/spring-projects/spring-security
  • github.com/spring-projects/spring-security/commit/d0f93fa6d8338149943ae640c53db07de827867f
  • github.com/spring-projects/spring-security/commit/e5694ac7b5e4394b920c6cab48b7bfbd871f84bd
  • github.com/spring-projects/spring-security/issues/17898
  • github.com/spring-projects/spring-security/issues/17899
  • github.com/spring-projects/spring-security/releases/tag/6.4.10
  • github.com/spring-projects/spring-security/releases/tag/6.5.4
  • nvd.nist.gov/vuln/detail/CVE-2025-41248
  • spring.io/security/cve-2025-41248

Code Behaviors & Features

Detect and mitigate CVE-2025-41248 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 6.4.0 before 6.4.10, all versions starting from 6.5.0 before 6.5.4

Fixed versions

  • 6.4.10
  • 6.5.4

Solution

Upgrade to versions 6.4.10, 6.5.4 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.springframework.security/spring-security-core/CVE-2025-41248.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:29 +0000.