CVE-2023-20873: Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry
(updated )
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
References
- github.com/advisories/GHSA-g5h3-w546-pj7f
- github.com/spring-projects/spring-boot/commit/32444fed4b51cc58dc908467f706102d7f0bfc15
- github.com/spring-projects/spring-boot/commit/3522714c13b47af03bf42e7f2d5994af568cb1a7
- github.com/spring-projects/spring-boot/releases/tag/v2.7.11
- github.com/spring-projects/spring-boot/releases/tag/v3.0.6
- nvd.nist.gov/vuln/detail/CVE-2023-20873
- spring.io/security/cve-2023-20873
Code Behaviors & Features
Detect and mitigate CVE-2023-20873 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →