Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.owasp.esapi/esapi
  4. ›
  5. CVE-2010-3300

CVE-2010-3300: Reliance on Obfuscation or Encryption of Security-Relevant Inputs without Integrity Checking

August 13, 2021

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

References

  • github.com/advisories/GHSA-3gp6-hhfw-4gqx
  • nvd.nist.gov/vuln/detail/CVE-2010-3300
  • seclists.org/oss-sec/2010/q3/357
  • www.usenix.org/legacy/events/woot10/tech/full_papers/Rizzo.pdf

Code Behaviors & Features

Detect and mitigate CVE-2010-3300 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0ga

Fixed versions

  • 2.0GA

Solution

Upgrade to version 2.0GA or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-649: Reliance on Obfuscation or Encryption of Security-Relevant Inputs without Integrity Checking

Source file

maven/org.owasp.esapi/esapi/CVE-2010-3300.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.