Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.owasp.antisamy/antisamy
  4. ›
  5. CVE-2017-14735

CVE-2017-14735: Cross-site Scripting

September 25, 2017 (updated January 16, 2019)

OWASP AntiSamy before allows XSS via HTML5 entities.

References

  • github.com/nahsra/antisamy/issues/10
  • nvd.nist.gov/vuln/detail/CVE-2017-14735

Code Behaviors & Features

Detect and mitigate CVE-2017-14735 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.7

Fixed versions

  • 1.5.7

Solution

Upgrade to version 1.5.7 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.owasp.antisamy/antisamy/CVE-2017-14735.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.