Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.opensearch/opensearch
  4. ›
  5. GMS-2023-5381

GMS-2023-5381: OpenSearch StackOverflow vulnerability

December 1, 2023

Impact

A flaw was discovered in OpenSearch, affecting the _search API that allowed a specially crafted query string to cause a Stack Overflow and ultimately a Denial of Service.

The issue was identified by Elastic Engineering and corresponds to security advisory ESA-2023-14 (CVE-2023-31419).

Mitigation

Versions 1.3.14 and 2.11.1 contain a fix for this issue.

For more information

If you have any questions or comments about this advisory, please contact AWS/Amazon Security via our issue reporting page (https://aws.amazon.com/security/vulnerability-reporting/) or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue.

References

  • github.com/advisories/GHSA-6g3j-p5g6-992f
  • github.com/opensearch-project/OpenSearch/security/advisories/GHSA-6g3j-p5g6-992f

Code Behaviors & Features

Detect and mitigate GMS-2023-5381 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.14, all versions starting from 2.0.0 before 2.11.1

Fixed versions

  • 1.3.14
  • 2.11.1

Solution

Upgrade to versions 1.3.14, 2.11.1 or above.

Source file

maven/org.opensearch/opensearch/GMS-2023-5381.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:45 +0000.