Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.opensearch/opensearch-common
  4. ›
  5. CVE-2025-9624

CVE-2025-9624: OpenSearch is vulnerable to DoS via complex query_string inputs

November 25, 2025 (updated January 22, 2026)

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs.

This issue affects all OpenSearch versions below 2.19.4 and versions 3.0.0 through 3.2.0.

References

  • caverav.cl/posts/opensearch-dos/opensearch-dos
  • fluidattacks.com/advisories/chick
  • github.com/advisories/GHSA-mw3v-mmfw-3x2g
  • github.com/opensearch-project/OpenSearch
  • github.com/opensearch-project/OpenSearch/pull/19491
  • github.com/opensearch-project/OpenSearch/releases/tag/2.19.4
  • github.com/opensearch-project/OpenSearch/releases/tag/3.3.0
  • nvd.nist.gov/vuln/detail/CVE-2025-9624
  • opensearch.org/blog/explore-opensearch-3-3

Code Behaviors & Features

Detect and mitigate CVE-2025-9624 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.19.4, all versions starting from 3.0.0 before 3.3.0

Fixed versions

  • 3.3.0
  • 2.19.4

Solution

Upgrade to versions 2.19.4, 3.3.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-674: Uncontrolled Recursion

Source file

maven/org.opensearch/opensearch-common/CVE-2025-9624.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.