Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.opensearch.plugin/opensearch-security
  4. ›
  5. GHSA-22vx-2x23-98w6

GHSA-22vx-2x23-98w6: OpenSearch vulnerable to improper authorization for Rollover Requests

May 7, 2026

A flaw was identified in the OpenSearch Security plugin’s handling of index rollover requests. When a rollover request included an explicit target index name, the security plugin did not properly evaluate access control permissions against the target index. This could allow a user with rollover permissions on a source index to create a new index with a name they are not authorized to use.

References

  • github.com/advisories/GHSA-22vx-2x23-98w6
  • github.com/opensearch-project/security/security/advisories/GHSA-22vx-2x23-98w6

Code Behaviors & Features

Detect and mitigate GHSA-22vx-2x23-98w6 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.0 before 2.19.4, all versions starting from 3.0.0 before 3.2.0

Fixed versions

  • 2.19.4
  • 3.2.0

Solution

Upgrade to versions 2.19.4, 3.2.0 or above.

Impact 2.2 LOW

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.opensearch.plugin/opensearch-security/GHSA-22vx-2x23-98w6.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.