Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.opensearch.plugin/opensearch-security
  4. ›
  5. CVE-2022-41918

CVE-2022-41918: Incorrect Authorization

March 7, 2023

OpenSearch is a community-driven, open source fork of Elasticsearch and Kibana. There is an issue with the implementation of fine-grained access control rules (document-level security, field-level security and field masking) where they are not correctly applied to the indices that back data streams potentially leading to incorrect access authorization. OpenSearch 1.3.7 and 2.4.0 contain a fix for this issue. Users are advised to update. There are no known workarounds for this issue.

References

  • github.com/advisories/GHSA-wmx7-x4jp-9jgg
  • github.com/opensearch-project/security/commit/f7cc569c9d3fa5d5432c76c854eed280d45ce6f4
  • github.com/opensearch-project/security/security/advisories/GHSA-wmx7-x4jp-9jgg
  • nvd.nist.gov/vuln/detail/CVE-2022-41918

Code Behaviors & Features

Detect and mitigate CVE-2022-41918 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.7, all versions starting from 2.0.0 before 2.4.0

Fixed versions

  • 1.3.7
  • 2.4.0

Solution

Upgrade to versions 1.3.7, 2.4.0 or above.

Impact 6.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.opensearch.plugin/opensearch-security/CVE-2022-41918.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.