Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.openidentityplatform.openam/openam-oauth2
  4. ›
  5. CVE-2026-48717

CVE-2026-48717: OpenAM OAuth Authorization Bypass via PKCE Challenge

June 29, 2026

Description

An Improper Authorization (CWE-285) issue in OpenAM’s OAuth2 authorization-code grant allows a PKCE-protected authorization code to be redeemed without the required code_verifier. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.

The authorize endpoint stores a code_challenge on the issued code, but the token endpoint only requires a code_verifier when the realm-wide codeVerifierEnforced setting is enabled, which ships disabled by default. With that setting off, the stored challenge is checked only if the caller supplies a verifier, so omitting the parameter skips PKCE verification entirely.

References

  • github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-4v2w-2wqp-mc85
  • github.com/advisories/GHSA-4v2w-2wqp-mc85
  • nvd.nist.gov/vuln/detail/CVE-2026-48717

Code Behaviors & Features

Detect and mitigate CVE-2026-48717 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 16.1.1

Fixed versions

  • 16.1.1

Solution

Upgrade to version 16.1.1 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-285: Improper Authorization

Source file

maven/org.openidentityplatform.openam/openam-oauth2/CVE-2026-48717.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:35 +0000.