Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.openidentityplatform.openam/openam-core
  4. ›
  5. CVE-2022-34298

CVE-2022-34298: NT auth module vulnerability in OpenAM

June 24, 2022 (updated June 25, 2022)

The NT auth module in OpenAM before 14.6.6 allows a “replace Samba username attack.”

References

  • github.com/OpenIdentityPlatform/OpenAM/compare/14.6.5...14.6.6
  • github.com/OpenIdentityPlatform/OpenAM/pull/514
  • github.com/OpenIdentityPlatform/OpenAM/releases/tag/14.6.6
  • github.com/advisories/GHSA-px3r-27qc-hx5g
  • nvd.nist.gov/vuln/detail/CVE-2022-34298

Code Behaviors & Features

Detect and mitigate CVE-2022-34298 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 14.6.6

Fixed versions

  • 14.6.6

Solution

Upgrade to version 14.6.6 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Source file

maven/org.openidentityplatform.openam/openam-core/CVE-2022-34298.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:18 +0000.