Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.opencrx/opencrx-client
  4. ›
  5. CVE-2022-40084

CVE-2022-40084: Observable Discrepancy

October 20, 2022 (updated November 8, 2022)

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

References

  • cwe.mitre.org/data/definitions/204.html
  • github.com/advisories/GHSA-j5v3-363p-g843
  • github.com/ciph0x01/OpenCRX-CVE/blob/main/CVE-2022-40084.md
  • nvd.nist.gov/vuln/detail/CVE-2022-40084

Code Behaviors & Features

Detect and mitigate CVE-2022-40084 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.2.2

Fixed versions

  • 5.2.2

Solution

Upgrade to version 5.2.2 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-203: Observable Discrepancy

Source file

maven/org.opencrx/opencrx-client/CVE-2022-40084.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:36 +0000.