Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.kohsuke/libpam4j
  4. ›
  5. CVE-2017-12197

CVE-2017-12197: Improper Input Validation

May 13, 2022 (updated July 1, 2022)

It was found that libpam4j up to and including 1.8 does not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.

References

  • access.redhat.com/errata/RHSA-2017:2904
  • access.redhat.com/errata/RHSA-2017:2905
  • access.redhat.com/errata/RHSA-2017:2906
  • bugzilla.redhat.com/show_bug.cgi?id=1503103
  • github.com/advisories/GHSA-x9rg-q5fx-fx66
  • github.com/kohsuke/libpam4j/commit/02ffdff218283629ba4a902e7fe2fd44646abc21
  • github.com/kohsuke/libpam4j/issues/18
  • lists.debian.org/debian-lts-announce/2017/11/msg00008.html
  • nvd.nist.gov/vuln/detail/CVE-2017-12197
  • www.debian.org/security/2017/dsa-4025

Code Behaviors & Features

Detect and mitigate CVE-2017-12197 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10

Fixed versions

  • 1.10

Solution

Upgrade to version 1.10 or above.

Impact 6.5 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.kohsuke/libpam4j/CVE-2017-12197.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.