Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.keycloak/keycloak-services
  4. ›
  5. CVE-2018-10894

CVE-2018-10894: Improper Certificate Validation

May 13, 2022 (updated October 6, 2023)

It was found that SAML authentication in Keycloak 3.4.3.Final incorrectly authenticated expired certificates. A malicious user could use this to access unauthorized data or possibly conduct further attacks.

References

  • access.redhat.com/errata/RHSA-2018:3592
  • access.redhat.com/errata/RHSA-2018:3593
  • access.redhat.com/errata/RHSA-2018:3595
  • access.redhat.com/errata/RHSA-2019:0877
  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10894
  • github.com/advisories/GHSA-xvv8-8wh9-9fh2
  • github.com/keycloak/keycloak/commit/812e76c39b1e693e8f11e5549cca2c90631f372e
  • nvd.nist.gov/vuln/detail/CVE-2018-10894

Code Behaviors & Features

Detect and mitigate CVE-2018-10894 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.4.0.final

Fixed versions

  • 4.4.0.Final

Solution

Upgrade to version 4.4.0.Final or above.

Impact 5.4 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

maven/org.keycloak/keycloak-services/CVE-2018-10894.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:01 +0000.