Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jvnet.hudson.plugins/warnings
  4. ›
  5. CVE-2019-1003007

CVE-2019-1003007: Cross-Site Request Forgery (CSRF)

May 13, 2022 (updated January 30, 2024)

A cross-site request forgery vulnerability exists in Jenkins Warnings Plugin 5.0.0 and earlier in src/main/java/hudson/plugins/warnings/GroovyParser.java that allows attackers to execute arbitrary code via a form validation HTTP endpoint.

References

  • github.com/advisories/GHSA-mmrv-3cqg-hpf9
  • jenkins.io/security/advisory/2019-01-28/
  • jenkins.io/security/advisory/2019-01-28/
  • nvd.nist.gov/vuln/detail/CVE-2019-1003007

Code Behaviors & Features

Detect and mitigate CVE-2019-1003007 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 5.0.0

Fixed versions

  • 5.0.1

Solution

Upgrade to version 5.0.1 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)
  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

maven/org.jvnet.hudson.plugins/warnings/CVE-2019-1003007.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.