Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jruby/jruby-stdlib
  4. ›
  5. CVE-2018-1000077

CVE-2018-1000077: Improper Input Validation

May 14, 2022 (updated March 10, 2023)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.

References

  • blog.rubygems.org/2018/02/15/2.7.6-released.html
  • lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
  • access.redhat.com/errata/RHSA-2018:3729
  • access.redhat.com/errata/RHSA-2018:3730
  • access.redhat.com/errata/RHSA-2018:3731
  • access.redhat.com/errata/RHSA-2019:2028
  • access.redhat.com/errata/RHSA-2020:0542
  • access.redhat.com/errata/RHSA-2020:0591
  • access.redhat.com/errata/RHSA-2020:0663
  • github.com/advisories/GHSA-gv86-43rv-79m2
  • github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7
  • github.com/rubygems/rubygems/commit/5971b486d4dbb2bad5d3445b3801c456eb0ce183
  • github.com/rubygems/rubygems/commit/feadefc2d351dcb95d6492f5ad17ebca546eb964
  • lists.debian.org/debian-lts-announce/2018/04/msg00000.html
  • lists.debian.org/debian-lts-announce/2018/04/msg00001.html
  • lists.debian.org/debian-lts-announce/2018/04/msg00023.html
  • lists.debian.org/debian-lts-announce/2018/07/msg00012.html
  • lists.debian.org/debian-lts-announce/2019/05/msg00028.html
  • nvd.nist.gov/vuln/detail/CVE-2018-1000077
  • usn.ubuntu.com/3621-1/
  • www.debian.org/security/2018/dsa-4219
  • www.debian.org/security/2018/dsa-4259

Code Behaviors & Features

Detect and mitigate CVE-2018-1000077 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.1.16.0

Fixed versions

  • 9.1.16.0

Solution

Upgrade to version 9.1.16.0 or above.

Impact 5.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.jruby/jruby-stdlib/CVE-2018-1000077.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:09 +0000.