CVE-2018-1000076: Improper Verification of Cryptographic Signature
(updated )
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.
References
- blog.rubygems.org/2018/02/15/2.7.6-released.html
- lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- access.redhat.com/errata/RHSA-2018:3729
- access.redhat.com/errata/RHSA-2018:3730
- access.redhat.com/errata/RHSA-2018:3731
- access.redhat.com/errata/RHSA-2019:2028
- access.redhat.com/errata/RHSA-2020:0542
- access.redhat.com/errata/RHSA-2020:0591
- access.redhat.com/errata/RHSA-2020:0663
- github.com/advisories/GHSA-mc6j-h948-v2p6
- github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7
- github.com/rubygems/rubygems/commit/f5042b879259b1f1ce95a0c5082622c646376693
- lists.debian.org/debian-lts-announce/2018/04/msg00000.html
- lists.debian.org/debian-lts-announce/2018/04/msg00001.html
- lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- lists.debian.org/debian-lts-announce/2019/05/msg00028.html
- nvd.nist.gov/vuln/detail/CVE-2018-1000076
- usn.ubuntu.com/3621-1/
- www.debian.org/security/2018/dsa-4219
- www.debian.org/security/2018/dsa-4259
Code Behaviors & Features
Detect and mitigate CVE-2018-1000076 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →