Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jooby/jooby
  4. ›
  5. CVE-2019-15477

CVE-2019-15477: Cross-site Scripting

August 23, 2019 (updated July 18, 2023)

Jooby before has XSS via the default error handler.

References

  • github.com/jooby-project/jooby/commit/27b4af283de1a2c2a6b0530039b46eef75ddf655
  • github.com/jooby-project/jooby/pull/1368
  • nvd.nist.gov/vuln/detail/CVE-2019-15477

Code Behaviors & Features

Detect and mitigate CVE-2019-15477 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.4

Fixed versions

  • 1.6.4

Solution

Upgrade to version 1.6.4 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jooby/jooby/CVE-2019-15477.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:48 +0000.