Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkinsci.plugins/octoperf
  4. ›
  5. CVE-2023-28671

CVE-2023-28671: Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery

April 2, 2023 (updated February 25, 2025)

OctoPerf Load Testing Plugin Plugin 4.5.0 and earlier does not require POST requests for a connection test HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.

This vulnerability allows attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

OctoPerf Load Testing Plugin Plugin 4.5.1 requires POST requests for the affected connection test HTTP endpoint.

References

  • github.com/advisories/GHSA-wq3w-3rxh-vcxx
  • nvd.nist.gov/vuln/detail/CVE-2023-28671
  • www.jenkins.io/security/advisory/2023-03-21/

Code Behaviors & Features

Detect and mitigate CVE-2023-28671 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.5.1

Fixed versions

  • 4.5.1

Solution

Upgrade to version 4.5.1 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

maven/org.jenkinsci.plugins/octoperf/CVE-2023-28671.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:59 +0000.