Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci/update-center2
  4. ›
  5. CVE-2023-27905

CVE-2023-27905: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

March 10, 2023 (updated March 16, 2023)

Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a plugin for hosting.

References

  • github.com/advisories/GHSA-pqg3-xfx2-fmqp
  • nvd.nist.gov/vuln/detail/CVE-2023-27905
  • www.jenkins.io/security/advisory/2023-03-08/

Code Behaviors & Features

Detect and mitigate CVE-2023-27905 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.13 before 3.15

Fixed versions

  • 3.15

Solution

Upgrade to version 3.15 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci/update-center2/CVE-2023-27905.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.