Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/zos-connector
  4. ›
  5. CVE-2018-1000608

CVE-2018-1000608: Insufficiently Protected Credentials

June 26, 2018 (updated October 3, 2019)

A vulnerability exists in the Jenkins z/OS Connector Plugin. It allows an attacker with local file system access or control of a Jenkins administrator’s web browser to retrieve the configured password.

References

  • jenkins.io/security/advisory/2018-06-25/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000608

Code Behaviors & Features

Detect and mitigate CVE-2018-1000608 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.2.6.1

Fixed versions

  • 2.0

Solution

Upgrade to version 2.0 or above.

Impact 7.2 HIGH

CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/org.jenkins-ci.plugins/zos-connector/CVE-2018-1000608.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:08 +0000.