Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/vncrecorder
  4. ›
  5. CVE-2020-2206

CVE-2020-2206: Cross-site Scripting

July 2, 2020 (updated July 9, 2020)

Jenkins VncRecorder Plugin does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.

References

  • jenkins.io/security/advisory/2020-07-02/
  • nvd.nist.gov/vuln/detail/CVE-2020-2206

Code Behaviors & Features

Detect and mitigate CVE-2020-2206 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.25

Fixed versions

  • 1.35

Solution

Upgrade to version 1.35 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.plugins/vncrecorder/CVE-2020-2206.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:19 +0000.