Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/translation
  4. ›
  5. CVE-2018-1000014

CVE-2018-1000014: Cross-Site Request Forgery (CSRF)

May 14, 2022 (updated January 30, 2024)

Jenkins Translation Assistance Plugin 1.15 and earlier does not require form submissions to be submitted via POST, resulting in a CSRF vulnerability allowing attackers to override localized strings displayed to all users on the current Jenkins instance if the victim is a Jenkins administrator.

References

  • www.securityfocus.com/bid/102809
  • github.com/advisories/GHSA-pwvj-6phx-qv8c
  • jenkins.io/security/advisory/2018-01-22/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000014

Code Behaviors & Features

Detect and mitigate CVE-2018-1000014 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.15

Fixed versions

  • 1.16

Solution

Upgrade to version 1.16 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)
  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

maven/org.jenkins-ci.plugins/translation/CVE-2018-1000014.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:40 +0000.