Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/synopsys-coverity
  4. ›
  5. CVE-2023-23848

CVE-2023-23848: Incorrect Default Permissions

February 15, 2023 (updated January 30, 2024)

Missing permission checks in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

References

  • community.synopsys.com/s/article/SIG-Product-Security-Advisory-Multiple-CVEs-affecting-Coverity-Jenkins-Plugin
  • github.com/advisories/GHSA-c3v2-5388-v8pw
  • nvd.nist.gov/vuln/detail/CVE-2023-23848
  • www.jenkins.io/security/advisory/2023-02-15/

Code Behaviors & Features

Detect and mitigate CVE-2023-23848 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 3.0.2

Fixed versions

  • 3.0.3

Solution

Upgrade to version 3.0.3 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-276: Incorrect Default Permissions

Source file

maven/org.jenkins-ci.plugins/synopsys-coverity/CVE-2023-23848.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:03 +0000.