Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/swarm-client
  4. ›
  5. CVE-2017-1000402

CVE-2017-1000402: Improper Input Validation

May 14, 2022 (updated November 22, 2022)

Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.

References

  • github.com/advisories/GHSA-pj45-8vhc-mh2f
  • jenkins.io/security/advisory/2017-10-11/
  • nvd.nist.gov/vuln/detail/CVE-2017-1000402

Code Behaviors & Features

Detect and mitigate CVE-2017-1000402 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 3.4

Fixed versions

  • 3.5

Solution

Upgrade to version 3.5 or above.

Impact 5.9 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.jenkins-ci.plugins/swarm-client/CVE-2017-1000402.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:57 +0000.