Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/ssh-slaves
  4. ›
  5. CVE-2017-2648

CVE-2017-2648: Improper Certificate Validation

May 13, 2022 (updated January 30, 2024)

It was found that jenkins-ssh-slaves-plugin before version 1.15 does not perform host key verification, thereby enabling Man-in-the-Middle attacks.

References

  • www.securityfocus.com/bid/96985
  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2648
  • github.com/advisories/GHSA-x654-4wjh-74q6
  • jenkins.io/security/advisory/2017-03-20/
  • nvd.nist.gov/vuln/detail/CVE-2017-2648

Code Behaviors & Features

Detect and mitigate CVE-2017-2648 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.15

Fixed versions

  • 1.15

Solution

Upgrade to version 1.15 or above.

Impact 5.6 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

maven/org.jenkins-ci.plugins/ssh-slaves/CVE-2017-2648.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:34 +0000.