Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/script-security
  4. ›
  5. CVE-2019-16538

CVE-2019-16538: Incorrect Authorization

November 21, 2019 (updated December 3, 2019)

A sandbox bypass vulnerability in Jenkins Script Security Plugin related to the handling of default parameter expressions in closures allows attackers to execute arbitrary code in sandboxed scripts.

References

  • jenkins.io/security/advisory/2019-11-21/
  • nvd.nist.gov/vuln/detail/CVE-2019-16538

Code Behaviors & Features

Detect and mitigate CVE-2019-16538 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.67

Fixed versions

  • 1.68

Solution

Upgrade to version 1.68 or above.

Impact 10 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.jenkins-ci.plugins/script-security/CVE-2019-16538.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:37 +0000.