Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/script-security
  4. ›
  5. CVE-2018-1000865

CVE-2018-1000865: Improper Privilege Management

December 10, 2018 (updated October 3, 2019)

A sandbox bypass vulnerability exists in Script Security Plugin that allows attackers with Job/Configure permission to execute arbitrary code on the Jenkins master JVM, if plugins using the Groovy sandbox are installed.

References

  • jenkins.io/security/advisory/2018-10-29/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000865

Code Behaviors & Features

Detect and mitigate CVE-2018-1000865 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.47

Fixed versions

  • 1.48

Solution

Upgrade to version 1.48 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

maven/org.jenkins-ci.plugins/script-security/CVE-2018-1000865.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:50 +0000.