Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/resource-disposer
  4. ›
  5. CVE-2018-1999037

CVE-2018-1999037: Improper Input Validation

August 1, 2018 (updated October 10, 2018)

A data modification vulnerability exists in Jenkins Resource Disposer Plugin in AsyncResourceDisposer.java that allows attackers to stop tracking a resource.

References

  • jenkins.io/security/advisory/2018-07-30/
  • nvd.nist.gov/vuln/detail/CVE-2018-1999037

Code Behaviors & Features

Detect and mitigate CVE-2018-1999037 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.11

Fixed versions

  • 0.12

Solution

Upgrade to version 0.12 or above.

Impact 4.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.jenkins-ci.plugins/resource-disposer/CVE-2018-1999037.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:56 +0000.