Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/repository-connector
  4. ›
  5. CVE-2021-21618

CVE-2021-21618: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

May 24, 2022 (updated December 13, 2022)

Jenkins Repository Connector Plugin 2.0.2 and earlier does not escape parameter names and descriptions for past builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

References

  • github.com/advisories/GHSA-hg2w-3c4j-jjwm
  • nvd.nist.gov/vuln/detail/CVE-2021-21618
  • www.jenkins.io/security/advisory/2021-02-24/

Code Behaviors & Features

Detect and mitigate CVE-2021-21618 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.0.2

Fixed versions

  • 2.0.3

Solution

Upgrade to version 2.0.3 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.plugins/repository-connector/CVE-2021-21618.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:56 +0000.