Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/repository-connector
  4. ›
  5. CVE-2019-1003038

CVE-2019-1003038: Insufficiently Protected Credentials

May 13, 2022 (updated October 25, 2023)

An insufficiently protected credentials vulnerability exists in Jenkins Repository Connector Plugin 1.2.4 and earlier in src/main/java/org/jvnet/hudson/plugins/repositoryconnector/ArtifactDeployer.java, src/main/java/org/jvnet/hudson/plugins/repositoryconnector/Repository.java, src/main/java/org/jvnet/hudson/plugins/repositoryconnector/UserPwd.java that allows an attacker with local file system access or control of a Jenkins administrator’s web browser (e.g. malicious extension) to retrieve the password stored in the plugin configuration.

References

  • github.com/advisories/GHSA-99jc-v8pq-6qm4
  • jenkins.io/security/advisory/2019-03-06/
  • nvd.nist.gov/vuln/detail/CVE-2019-1003038
  • web.archive.org/web/20200227084009/http://www.securityfocus.com/bid/107476

Code Behaviors & Features

Detect and mitigate CVE-2019-1003038 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.2.4

Fixed versions

  • 1.2.5

Solution

Upgrade to version 1.2.5 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/org.jenkins-ci.plugins/repository-connector/CVE-2019-1003038.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.