Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/publish-over-ssh
  4. ›
  5. CVE-2022-23110

CVE-2022-23110: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

January 13, 2022 (updated November 29, 2022)

Jenkins Publish Over SSH Plugin 1.22 and earlier does not escape the SSH server name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission.

References

  • www.openwall.com/lists/oss-security/2022/01/12/6
  • github.com/advisories/GHSA-fjpm-hf7c-xgc2
  • github.com/jenkinsci/publish-over-ssh-plugin/releases/tag/publish-over-ssh-1.23
  • nvd.nist.gov/vuln/detail/CVE-2022-23110
  • www.jenkins.io/security/advisory/2022-01-12/

Code Behaviors & Features

Detect and mitigate CVE-2022-23110 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.23

Fixed versions

  • 1.23

Solution

Upgrade to version 1.23 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.plugins/publish-over-ssh/CVE-2022-23110.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:45 +0000.