Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/publish-over-cifs
  4. ›
  5. CVE-2018-1999038

CVE-2018-1999038: Unintended Proxy or Intermediary (Confused Deputy)

August 1, 2018 (updated October 15, 2018)

A confused deputy vulnerability exists in Jenkins Publisher Over CIFS Plugin in CifsPublisherPluginDescriptor.java that allows attackers to have Jenkins connect to an attacker specified CIFS server with attacker specified credentials.

References

  • jenkins.io/security/advisory/2018-07-30/
  • nvd.nist.gov/vuln/detail/CVE-2018-1999038

Code Behaviors & Features

Detect and mitigate CVE-2018-1999038 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.10

Fixed versions

  • 0.11

Solution

Upgrade to version 0.11 or above.

Impact 4.2 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-441: Unintended Proxy or Intermediary ('Confused Deputy')

Source file

maven/org.jenkins-ci.plugins/publish-over-cifs/CVE-2018-1999038.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:58 +0000.