Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/libvirt-slave
  4. ›
  5. CVE-2021-21627

CVE-2021-21627: Cross-Site Request Forgery (CSRF)

May 24, 2022 (updated December 22, 2022)

A cross-site request forgery (CSRF) vulnerability in Jenkins Libvirt Agents Plugin 1.9.0 and earlier allows attackers to stop hypervisor domains.

References

  • www.openwall.com/lists/oss-security/2021/03/18/5
  • github.com/advisories/GHSA-mm5c-7mpr-99fm
  • nvd.nist.gov/vuln/detail/CVE-2021-21627
  • www.jenkins.io/security/advisory/2021-03-18/

Code Behaviors & Features

Detect and mitigate CVE-2021-21627 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.9.0

Fixed versions

  • 1.9.1

Solution

Upgrade to version 1.9.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)
  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

maven/org.jenkins-ci.plugins/libvirt-slave/CVE-2021-21627.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:21 +0000.