Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/jacoco
  4. ›
  5. CVE-2023-28669

CVE-2023-28669: Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting

April 2, 2023 (updated February 25, 2025)

Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the ‘Record JaCoCo coverage report’ post-build action. Version 3.3.2.1 escapes class and method names shown on the UI.

References

  • github.com/advisories/GHSA-xj29-gfww-j67g
  • github.com/jenkinsci/jacoco-plugin/commit/96386f94b00e8802c4905b58e5c3dc4fa4a7c1cd
  • nvd.nist.gov/vuln/detail/CVE-2023-28669
  • www.jenkins.io/security/advisory/2023-03-21/

Code Behaviors & Features

Detect and mitigate CVE-2023-28669 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.3.2.1

Fixed versions

  • 3.3.2.1

Solution

Upgrade to version 3.3.2.1 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.plugins/jacoco/CVE-2023-28669.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.