Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/hp-application-automation-tools-plugin
  4. ›
  5. CVE-2021-22511

CVE-2021-22511: Improper Certificate Validation

May 24, 2022 (updated December 13, 2022)

Improper Certificate Validation vulnerability in Micro Focus Application Automation Tools Plugin - Jenkins plugin. The vulnerability affects version 6.7 and earlier versions. The vulnerability could allow unconditionally disabling of SSL/TLS certificates.

References

  • github.com/advisories/GHSA-q296-9j5x-fxf4
  • nvd.nist.gov/vuln/detail/CVE-2021-22511
  • www.jenkins.io/security/advisory/2021-04-07/

Code Behaviors & Features

Detect and mitigate CVE-2021-22511 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 6.7

Fixed versions

  • 6.8

Solution

Upgrade to version 6.8 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

maven/org.jenkins-ci.plugins/hp-application-automation-tools-plugin/CVE-2021-22511.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.