Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/git
  4. ›
  5. CVE-2018-1000110

CVE-2018-1000110: Incorrect Authorization

March 13, 2018 (updated October 3, 2019)

An improper authorization vulnerability exists in the Jenkins Git Plugin in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.

References

  • jenkins.io/security/advisory/2018-02-26/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000110

Code Behaviors & Features

Detect and mitigate CVE-2018-1000110 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 3.7.0

Fixed versions

  • 3.8

Solution

Upgrade to version 3.8 or above.

Impact 5.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.jenkins-ci.plugins/git/CVE-2018-1000110.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:16 +0000.