Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/fortify
  4. ›
  5. CVE-2023-4303

CVE-2023-4303: Jenkins Fortify Plugin HTML injection vulnerability

August 21, 2023 (updated August 24, 2023)

Jenkins Fortify Plugin 22.1.38 and earlier does not escape the error message for a form validation method, resulting in an HTML injection vulnerability.

References

  • github.com/advisories/GHSA-223m-pgcq-f3xg
  • github.com/jenkinsci/fortify-plugin/commit/357d7bfbcb0ff796ea7d078bee13159f1d000f5d
  • nvd.nist.gov/vuln/detail/CVE-2023-4303
  • www.jenkins.io/security/advisory/2023-08-16/

Code Behaviors & Features

Detect and mitigate CVE-2023-4303 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 22.2.39

Fixed versions

  • 22.2.39

Solution

Upgrade to version 22.2.39 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.plugins/fortify/CVE-2023-4303.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.