Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/crowd2
  4. ›
  5. CVE-2018-1000423

CVE-2018-1000423: Insufficiently Protected Credentials

May 13, 2022 (updated January 9, 2024)

An insufficiently protected credentials vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java, CrowdConfigurationService.java that allows attackers with local file system access to obtain the credentials used to connect to Crowd 2.

References

  • www.securityfocus.com/bid/106532
  • github.com/advisories/GHSA-cg6q-gp23-vwx8
  • github.com/jenkinsci/crowd2-plugin/commit/580be2a0dfb38d494420901f03555092b885a85f
  • jenkins.io/security/advisory/2018-09-25/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000423

Code Behaviors & Features

Detect and mitigate CVE-2018-1000423 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.0.0

Fixed versions

  • 2.0.1

Solution

Upgrade to version 2.0.1 or above.

Impact 7.8 HIGH

CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/org.jenkins-ci.plugins/crowd2/CVE-2018-1000423.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:39 +0000.