Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/crowd2
  4. ›
  5. CVE-2018-1000422

CVE-2018-1000422: Server-Side Request Forgery (SSRF)

May 14, 2022 (updated January 9, 2024)

An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

References

  • github.com/advisories/GHSA-grmg-5q49-mqmf
  • github.com/jenkinsci/crowd2-plugin/commit/a93d0fa221454adb4087520d8c1c087828211598
  • jenkins.io/security/advisory/2018-09-25/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000422
  • web.archive.org/web/20200227092927/http://www.securityfocus.com/bid/106532

Code Behaviors & Features

Detect and mitigate CVE-2018-1000422 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.0.0

Fixed versions

  • 2.0.1

Solution

Upgrade to version 2.0.1 or above.

Impact 6.5 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

maven/org.jenkins-ci.plugins/crowd2/CVE-2018-1000422.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:13 +0000.