Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/credentials
  4. ›
  5. CVE-2020-2182

CVE-2020-2182: Insufficiently Protected Credentials

May 24, 2022 (updated June 24, 2022)

Jenkins Credentials Binding Plugin 1.22 and earlier does not mask (i.e., replace with asterisks) secrets containing a $ character in some circumstances.

References

  • www.openwall.com/lists/oss-security/2020/05/06/3
  • github.com/advisories/GHSA-7ff8-qfwx-8gx5
  • jenkins.io/security/advisory/2020-05-06/
  • nvd.nist.gov/vuln/detail/CVE-2020-2182

Code Behaviors & Features

Detect and mitigate CVE-2020-2182 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.22

Fixed versions

  • 1.23

Solution

Upgrade to version 1.23 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/org.jenkins-ci.plugins/credentials/CVE-2020-2182.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.