Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/coverity
  4. ›
  5. CVE-2018-1000104

CVE-2018-1000104: Insufficiently Protected Credentials

March 13, 2018 (updated October 3, 2019)

A plaintext storage of a password vulnerability exists in the Jenkins Coverity Plugin that allows an attacker with local file system access or control of a Jenkins administrator’s web browser to retrieve the configured keystore and private key passwords.

References

  • jenkins.io/security/advisory/2018-02-26/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000104

Code Behaviors & Features

Detect and mitigate CVE-2018-1000104 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.10.0

Fixed versions

  • 1.11

Solution

Upgrade to version 1.11 or above.

Impact 7.8 HIGH

CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/org.jenkins-ci.plugins/coverity/CVE-2018-1000104.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.