Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/appdynamics-dashboard
  4. ›
  5. CVE-2019-1003039

CVE-2019-1003039: Insufficiently Protected Credentials

May 13, 2022 (updated October 25, 2023)

An insufficiently protected credentials vulnerability exists in JenkinsAppDynamics Dashboard Plugin 1.0.14 and earlier in src/main/java/nl/codecentric/jenkins/appd/AppDynamicsResultsPublisher.java that allows attackers without permission to obtain passwords configured in jobs to obtain them.

References

  • github.com/advisories/GHSA-mmqx-g78c-hvfj
  • jenkins.io/security/advisory/2019-03-06/
  • nvd.nist.gov/vuln/detail/CVE-2019-1003039
  • web.archive.org/web/20200227084009/http://www.securityfocus.com/bid/107476

Code Behaviors & Features

Detect and mitigate CVE-2019-1003039 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.0.14

Fixed versions

  • 1.0.15

Solution

Upgrade to version 1.0.15 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/org.jenkins-ci.plugins/appdynamics-dashboard/CVE-2019-1003039.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:24 +0000.