Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/ansible
  4. ›
  5. CVE-2018-1000149

CVE-2018-1000149: Improper Certificate Validation

April 5, 2018 (updated May 15, 2018)

A man in the middle vulnerability exists in the Jenkins Ansible Plugin that disables host key verification by default.

References

  • jenkins.io/security/advisory/2018-03-26/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000149

Code Behaviors & Features

Detect and mitigate CVE-2018-1000149 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.8

Fixed versions

  • 1.0

Solution

Upgrade to version 1.0 or above.

Impact 5.6 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Source file

maven/org.jenkins-ci.plugins/ansible/CVE-2018-1000149.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.