Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins/anchore-container-scanner
  4. ›
  5. CVE-2022-41225

CVE-2022-41225: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

September 21, 2022 (updated November 1, 2023)

Jenkins Anchore Container Image Scanner Plugin 1.0.24 and earlier does not escape content provided by the Anchore engine API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control API responses by Anchore engine.

References

  • nvd.nist.gov/vuln/detail/CVE-2022-41225
  • www.jenkins.io/security/advisory/2022-09-21/

Code Behaviors & Features

Detect and mitigate CVE-2022-41225 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.0.25

Fixed versions

  • 1.0.25

Solution

Upgrade to version 1.0.25 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.plugins/anchore-container-scanner/CVE-2022-41225.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.