Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins.workflow/workflow-cps
  4. ›
  5. CVE-2022-25180

CVE-2022-25180: Insufficiently Protected Credentials

February 16, 2022 (updated August 15, 2022)

Jenkins Pipeline: Groovy Plugin 2648.va9433432b33c and earlier includes password parameters from the original build in replayed builds, allowing attackers with Run/Replay permission to obtain the values of password parameters passed to previous builds of a Pipeline.

References

  • github.com/advisories/GHSA-qv6q-x9vr-w7j3
  • nvd.nist.gov/vuln/detail/CVE-2022-25180
  • www.jenkins.io/security/advisory/2022-02-15/

Code Behaviors & Features

Detect and mitigate CVE-2022-25180 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2648.va9433432b33c

Fixed versions

  • 2648.2651.v230593e03e9f

Solution

Upgrade to version 2648.2651.v230593e03e9f or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/org.jenkins-ci.plugins.workflow/workflow-cps/CVE-2022-25180.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:19 +0000.