Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.plugins.workflow/workflow-cps
  4. ›
  5. CVE-2020-2109

CVE-2020-2109: Improper Input Validation

May 24, 2022 (updated June 24, 2022)

Sandbox protection in Jenkins Pipeline: Groovy Plugin 2.78 and earlier can be circumvented through default parameter expressions in CPS-transformed methods.

References

  • www.openwall.com/lists/oss-security/2020/02/12/3
  • github.com/advisories/GHSA-99mf-f3qh-wqrp
  • jenkins.io/security/advisory/2020-02-12/
  • nvd.nist.gov/vuln/detail/CVE-2020-2109

Code Behaviors & Features

Detect and mitigate CVE-2020-2109 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.78

Fixed versions

  • 2.79

Solution

Upgrade to version 2.79 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.jenkins-ci.plugins.workflow/workflow-cps/CVE-2020-2109.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.